summaryrefslogtreecommitdiff
path: root/diffuse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'diffuse/APKBUILD')
-rw-r--r--diffuse/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/diffuse/APKBUILD b/diffuse/APKBUILD
new file mode 100644
index 0000000..632abb2
--- /dev/null
+++ b/diffuse/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: V.Krishn <vkrishn@insteps.net>
+pkgname=diffuse
+pkgver=0.7.7
+pkgrel=1
+pkgdesc="Graphical tool for comparing and merging text files"
+url="https://github.com/MightyCreak/diffuse"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="
+ gdk-pixbuf
+ gtk+3.0
+ pango
+ py3-gobject3
+ py3-cairo
+ "
+makedepends="
+ desktop-file-utils
+ gettext-dev
+ meson
+ "
+subpackages="$pkgname-lang $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/MightyCreak/diffuse/archive/refs/tags/v$pkgver.tar.gz"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+bf9576734ebd696252732b3b0ce6f1f18508a800520388459d9f27482a43251db879c2198c3a279bad9528afc08cf8e7f23a3253b58edad049db9b1c697fd6e0 diffuse-0.7.7.tar.gz
+"