summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorV.Krishn <vkrishn@insteps.net>2024-03-07 05:14:46 +0530
committerV.Krishn <vkrishn@insteps.net>2024-03-07 05:14:46 +0530
commitaa3f9d25d8fa194267cf3383b70591b7dafb03b1 (patch)
treefd67fffb9497b73aa86021dd8c7bc306228e898c
parent7b3e5526eb573f4b82d10ece85a9e636daffa39e (diff)
downloadaportsbag-aa3f9d25d8fa194267cf3383b70591b7dafb03b1.tar.bz2
add diffuse
-rw-r--r--diffuse/APKBUILD39
-rw-r--r--diffuse/diffuse.tests.txt12
2 files changed, 51 insertions, 0 deletions
diff --git a/diffuse/APKBUILD b/diffuse/APKBUILD
new file mode 100644
index 0000000..632abb2
--- /dev/null
+++ b/diffuse/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: V.Krishn <vkrishn@insteps.net>
+pkgname=diffuse
+pkgver=0.7.7
+pkgrel=1
+pkgdesc="Graphical tool for comparing and merging text files"
+url="https://github.com/MightyCreak/diffuse"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="
+ gdk-pixbuf
+ gtk+3.0
+ pango
+ py3-gobject3
+ py3-cairo
+ "
+makedepends="
+ desktop-file-utils
+ gettext-dev
+ meson
+ "
+subpackages="$pkgname-lang $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/MightyCreak/diffuse/archive/refs/tags/v$pkgver.tar.gz"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+bf9576734ebd696252732b3b0ce6f1f18508a800520388459d9f27482a43251db879c2198c3a279bad9528afc08cf8e7f23a3253b58edad049db9b1c697fd6e0 diffuse-0.7.7.tar.gz
+"
diff --git a/diffuse/diffuse.tests.txt b/diffuse/diffuse.tests.txt
new file mode 100644
index 0000000..803618b
--- /dev/null
+++ b/diffuse/diffuse.tests.txt
@@ -0,0 +1,12 @@
+
+
+MANUAL INSTALL
+apk add appstream-glib cairo desktop-file-utils gdk-pixbuf gettext-dev gtk+3.0 meson pango py3-cairo py3-gobject3 python3
+
+TESTS
+They show different result in v0.7.7 and v0.8.0+(all) upto v0.9.0
+
+
+diffuse -r ba476b5f71eab -r 324399e3d2a7 testing/diffuse/APKBUILD
+
+